How to stop FileZilla from storing my passwords?

last updated
created
1 reply
806 views
2 users
0 likes
anonymous_2 20 Jun 2011
When connecting to my server for ftp purposes, FileZilla tends to store my passwords as plain text in xml configuration files like sitemanager.xml or bookmarks.xml. Is there a way to stop it from doing that, I'd rather enter the passwords each time I connect.

1 Comment

Like what you see?

Our one-click login makes it easy to share your thoughts. You can ask your own questions, get email notification of replies to your posts, add your comments, and give a thumb-up to the things you like.

Just use your Facebook/Google/Clever Dodo account to login.

gices 20 Jun 2011
At first I thought that if you go into sFTP mode (SSH FTP), FileZilla won't store your passwords but no, it still will. sFTP will only make sure that your connection is encrypted, that's all.

To prevent Filezilla from storing your passwords, you will need to go into Kiosk mode. The way to do that is to look for C:\Program Files (x86)\FileZilla FTP Client\docs\fzdefaults.example.xml and edit this file. You will probably need to edit this with administrator's permission (run notepad as administrator and open that file).

Look for :
0

And change it to :
1

If there are other settings there, comment them by placing at the end of the line, otherwise you might receive an error when you start filezilla telling you that it can't save xml files.

Now rename fzdefaults.example.xml to fzdefaults.xml and place it at C:\Program Files (x86)\FileZilla FTP Client\ and when you choose a connection type, select "Ask for password" instead of "Normal" and FileZilla will not save any of your passwords again.

Remember to delete the entries in bookmarks.xml and sitemanager.xml if they already have your passwords.